Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

Game will not load, it stays stuck on the 'Loading Hero' screen

I’ve tried three times to load the game with no success.

Another person in my guild is having the same issue.

Same thing here, playing on iOS. iPad and phone get stuck on loading hero

i just finished a pvp fight and now stop in the loading animation (xbox one)

same - loading hero - cant progress further - using steam, tried using my phone & opened up but with error message saying “something has gone wrong”

I’m having the same issue. :expressionless:

The same on iOS

Ditto here on steam. I got the “PVP is done” message, as if the weekly reset had happened, so I closed and relaunched the game. Can’t get in.

It must have been just a server hiccup. I can log in now.

I can log in, but the game is stuck at the spinning wheel whenever I try to click on a tab.

So it seems that it’s Steam that’s down and that’s why I’m having issues.

Steam has been down for about 50 minutes or so…

Its mobile or nothing at this point.

1 Like

It’s the same for me also @mortagon. I figured it was due to steam gearing up for Christmas sales.

Cheers for this. Just ran into this myself and thought it was my phone’s teathered internet screwing up (yup, having internet issues with internet forcing one to use phone for teathering, just before Christmas sucks -_-).

I guess I’ll keep off GoW for now then… I can log in fine, but I’m guessing my progress won’t be synced.

Running into it on Steam/PC too…

Looks like Steam is not stable or its affecting loading of GoW

iOS here. Game loads, but then I get an infinite spinning wheel. It looks like most everything is loaded since my login mail updated today and I can see my home kingdom ready to collect, but the spinning wheel loading animation prevents ALL interaction with the game.

Been happening since last night. Have force closed and reopened the game several times.