Game not working :(

I was in chat 10 min before reset and Nim said make sure your steam is up to date before reset so I closed gow then steam, opened Steam then Gow to get updates… Now game wont load and poor Gizmo is getting “unrecoverable error” What did Nim do to Gizmo? Is my charecter lost or what is going on?

Same with me I keep getting this error message

Yep thats the one

Hello, same error for me. I close steam agent and restart it. Same problem

Exact same error, uninstall doesnt work.

Yep, happening to me too. Was working fine until I logged off and installed the update after reset.

I’m trying to kill all processes Steam (steam.exe and steamwebhelper) and I restart Steam. I receive an update from the platform steam. But always same error when I start Gem’s of War

I have the same error here. Not been able to start for the last 40 minutes?

Due to the way the new servers deploy things out… the new kingdom’s arrival is just delayed a little… it’ll be there shortly
It’s our first big release with the new servers, so we weren’t 100% sure how it would all go out.

Chat is down but kingdom is working for me

I’m in Kingdom now…

We’ve investigating Chat servers currently.

1 Like

Computer rebooted, steam kill and restarted, same problem
Ticket #23187 made
Good luck for your investigation

Game still not working for me. Rather you fix the logging first, then the useless chat function :slight_smile:

We’re currently investigating a problem… it looks like a corrupt or incorrect file may have made it out into the game… trying to figure out which one… a lot of files changed for silverglade, so it’s not as simple as diff’ing the files unfortunately

1 Like

Thank you Sirrian for your feed back

Well I still use my grandmother’s old sifter to separate the not wanted, wanna borrow that? Might help :slight_smile:

Good luck in finding the bug though, I’ll take some chill pills in the meanwhile!

Thanks for the update Sirrian


1 Like

Hey Siri: find the messed up file.

I’ve found three Mazda dealerships near your location.

Sorry, I tried.


Im in hurrrayyyy

Sirrian, it’s working for me. Thank you a lot