Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

[Fixed] New Achievement (505) bugged

Platform, device version and operating system: PC, Windows 7

Screenshot or image:

What you were expecting to happen, and what actually happened: Was using Thrall in cPVP. Cast several times. Won Match. No update on how many of one color were destroyed. Thrall destroys gems. If it’s supposed to be explode or remove gems IT NEEDS TO SAY THAT.

**How often does this happen? * Every time
It should at least give a counter to how close you get. That is not happening.

1 Like

Its not direct help since I’m on a different platform with a potential glitched achievement for Renown, Xbox One, but I had the 505 achievement unlock after the battle using an Egg Thief team and casting until the opponent died on Explore 12.

I just assumed Destroy meant Destroy and didnt try to explode or other things.

1 Like

Worked for me on ps4. Just spammed egg thief in explore 9. You might need 50+ casts clearing the entire board.

It could also be bugged, since the rest of them are.

1 Like

Tried Egg Thief. Counter still at zero. Looks like a PC bug.

I just completed it on Steam by spamming Egg Thief as well. I did some battles earlier and didn’t see the achievement update to reflect my highest attempts though.

1 Like

It looks like it’s all or nothing. The counter is bugged, so it seems to be a communication error between the game & Steam, which has happened before.

Summary

Doubt it’s a communication error. As an achievement hunter, I’ve seen this happen with many games. You think it should track but the devs don’t really intend for that to happen. They just have code for the achievement to unlock when you reach the threshold, no code to send a progress update.

I was wrong. They fixed it :stuck_out_tongue:

I’m curious to know if anyone has got this achievement whilst also losing the match?

It popped for me on the match summary screen after winning.

Should the progress bar even be updating? It’s 505 gems in one battle, so after you fail to earn it in a battle, you’re back to 0/505. I’m not sure how achievement tracking usually works for things like this, but it seems fine.

Please fully exit and re-open the game to get the fix.

Got the achievement after a lengthy explore 12 battle circling between Alchemist, Valkyrie and Apothecary. They should have included some sort of progress indicator.
What I noticed is that the achievement tracking seems to be a bit off; at times the bar goes down to a lower number after a fight.