[Fixed] Can not open GoW, Game Crashes

Platform, device version and operating system:

Screenshot or image:

What you were expecting to happen, and what actually happened:
Expecting the game open without crashing.

How often does this happen? When did it begin happening?
I have tried multiple times but I keep getting the same result.

Steps to make it happen again
Click on game

1 Like

Not going to say this will fix the issue, but just in case.


Hey, please let us know if the troubleshooting Sarcastic linked you works as that was what I was going to do anyway, sniped!

Another thing you can try is deleting your Gems of War save data. You won’t lose your game progress as it’s all stored on our game servers not on your console. The instructions for that can be found here:

1 Like

@Kafka it’s working now.

I didn’t try the above as it started working after a while. I was not the only one that was having this issue as at least 2 other guild members were having the same issue.

Sometimes we were able to get into the game but it would give us a 504 error saying that there was an issue connecting with your servers.

I’m pretty sure it was an issue on your end but it is working for me now but im not sure about everyone else.

1 Like

I’ve just done some digging and we did have lag alerts on the game server about 6 hours after you posted here.

I’ve also checked and it looks like there’s a wider spread issue affecting PSN and other services as well in the US at the moment, which is where our servers are located, however, currently our game servers are up.

Because the game needs access to PSN though there may be some issues connecting on Playstation right now until that’s resolved.


1 Like

Thanks @Kafka

Seems to be ok at the moment which is good.

1 Like