Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

(Fixed) Ascended Gold Ring - now all traits say "Unable to upgrade troop. Please contact support and try again"

Screenshot or image:

Screenshot: https://imgur.com/a/iLtppwm

What you were expecting to happen, and what actually happened:

This bug started after I ascended Gold Ring to the next level

Steps to make it happen again

Ascend Gold Ring

1 Like

I have the same issue if I go to any treasure troop and try to trait it.

+1

I was able to trait Coin Purse, but I’m actually also getting the error on Priest’s Chalice even tho it’s not ascended? weird

I have traited Coin Purse and Gold Ring.
They worked fine for me, but when I tried Priest’s Chalice it gave me the same error you’re having.

Thanks, we’re looking into this!

Here is the article to follow for updates
https://gemsofwar.zendesk.com/hc/en-us/articles/360000541396-Underworld-Troops-can-t-be-Traited-Unable-to-upgrade-Troop-

This is fixed, please restart your game to see the changes.

This has not been fixed on Xbox. I still have a Gold Ring, Priest’s Chalice, and King’s Crown that cannot be traited.

It can take a few hours for the fix to reach all platforms - can you please try again @dujas?

Just checked. Issue is still there at the moment.

The problem appears to finally be resolved on Xbox. All the treasures are once again traitable.

1 Like

Awesome, glad to hear this is resolved now!