Dragon Armor Bonuses Not Working


#1

Note: If you are absolutely uncomfortable reporting your bug publicly you can privately message @Cyrup or @Kafka with the completed bug template. Do not abuse this offer to message developers if you are otherwise comfortable posting your thread publicly. (Please remove this paragraph when submitting your report)

Please check the known issues list before posting a bug.

Platform, device version and operating system
e.g. Android, Samsung Galaxy S8, Nougat

Screenshot or image
If you are on a console simply take a photo using another device. A video is preferred. Try uploading to YouTube Privately.

What you were expecting to happen, and what actually happened
This is simply what you were trying to do and what happened instead. Example:
‘I was trying to start an Arena battle, but Gems of War loaded Broken Spire quest instead!’

How often does this happen? When did it begin happening?
Was this a once-off bug or has it been a consistent issue? Does it only happen after doinga particular game mode?

Steps to make it happen again
Do you know how to make this happen? Sometimes there are certain steps that can lead to a problem that may not be obvious!
Example: I lose once in the Arena.
I then exit to the world map.
I then tap on Broken Spire on the map and then tap Arena.
Broken Spire’s quest loads instead of the Arena


#2

just purchased dragon armor for 500 gems and the bonuses arent active yes the armor is equipped and reloaded game still not showing up


#3

Are you sure you equipped it in the Armor tab? The Appearance tab is just for visuals.


#4

What foutdottwoone said!

To check it’s equipped:

Hero > Armor Bonus > Select Dragon Armor. You can have Dragon armor equipped for the bonus but still keep a different armor for the appearance if you like. :slight_smile: