Disenchanting Troops


#1

Speaking for my wife, “StarTomcat663,” on XBOX. She tried to disenchant a card that was already leveled a mythic, but had extra cards. “Dryaid,” was one of these creatures which was mythic she tried to disenchant extra cards leaving just one, but as soon as she disenchant the extra cards, the computer disenchant the whole creature itself and removed “Dryaid,” from her collection. There were two other creatures occurred the same outcome in which she does not remember which ones she lost. Is there anyway to get these creatures back? She will not use disenchanting again if this issue is not fixed. My suggestion would be, fix it or get rid of it…


#2

She needs to contact support with a ticket. Check out the links/buttons on the top of the forums and i’m sure this can be fixed for her.


If anything would be important to give more details if she experienced some sort of lag or similar issues while disenchanting the troops, usually on PC/Mobile some lag and unresponsive commands happens when we play for long hours without pause. I’m not sure if the same applies to consoles.


#3

Are you sure she didn’t tell it disenchant all copies? It is a easy mistake to make.

Looking at the below screenshot it would disenchat all my copies of the troop.


#4

Please have your wife contact our support so we can help her further.


#5

E.g. would try leave one Abroth and dischant the 7, but the computer would go and do all 8 regardless, and say, " thanks playing," being sarcastic.