Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

[DEPLOYED A HOT FIX] New doom skull can't be generated

Platform, device version and operating system: android

Screenshot or image:

What you were expecting to happen, and what actually happened:
When one of the new doom skull (10 pts) are on the board, if one choose to generate those gem through a spell (like with Humility or Justice), instead of adding new skull, the board get’s filled with blank spaces that can’t be either matched or moved.

It also stop the ability to explode gems.

How often does this happen? When did it begin happening?
Since last update (5.5 I guess) and as of now, for two combats out of two.

Steps to make it happen again
-Start a combat with a troop that can select the gem it generates like Humility,
-When a 10pts skull is on the board, use the spell of that troop selecting that type of skull to be generated.

10 Likes

Tested, true!

6 Likes

Same here. Could reproduce it. This happen when I tried to reproduce simple skulls, not Uber Doomskulls. I tried it enough time with The Devoted troop that I made the game crash as it couldn’t shuffle the board anymore. It froze in the position you see in the screenshot.

I confirm it also prevent explosion from Mountain Crusher weapon.

It did not prevent the explosion of Doomskulls and Uber Doomskulls, which is the only way I know to remove empty squares.

It seemed to also prevent Clockwork Sphynx to destroy, but not Sycorax to duplicate normal gems.

3 Likes

You could still explode stuff? When I tried this first, Mountain Crusher did nothing at all after that first Devoted cast.

I was able to explode the empty spaces with skulls and those blanks go down when you match gems beneath them, so, invisible stone blocks?

17 Likes

As I said, I confirmed it PREVENT explosion from Mountain Crusher.

The only explosion working was matching Doomskulls or Uber Doomskulls. No spells here.

1 Like

Also of note: the OP is not correct. The blank spaces appear when you select regular skulls also. It is not only the +10 skulls that trigger this bug.

Edit: @Velmont I understand now. I wasn’t thinking about matching +5 and +10 skulls. Thanks for clarifying.

2 Likes

sigh

This was also reported in the Beta :man_facepalming: We didn’t know why it was happening, but this isn’t just an issue with live, it’s existed for a while.

Gotta meet those release deadlines though, right?

11 Likes

Are you telling @igniteice meme above is true?

1 Like

Very much so ^^’

Edit:
To be fair, there were a lot of bugs that WERE caught and fixed. It’s just unfortunate that despite fairly broken bugs like this being known beforehand, we still have to deal with them on live.

1 Like

5.5 and many other go against the principal of “patches”. These updates are SUPPOSED to fix more issues than they cause. They aren’t just meant to make more money.

Expansions =/ Updates/Patches

At this point I’ve never done coding before but feel like I’m smarter than whomever at 505 Games is physically leading the destruction of Gems of War with unrealistic release dates. Or lack of QA… whichever is at fault. The source material is a shitty AF publisher that has no clue what they are doing with games with a service.

Games that are just straight releases however, 505 Games does an amazing job with them.
giphy (6)

Ah, I see that this is a known issue, then. Just uploaded a video to warn folks about this.
https://youtu.be/4Qhtl8M43cM

1 Like

And now they “fixed” it by removing the ability to duplicate skulls altogether. I’ll need to change my team I guess.

We deployed a hot fix for this issue yesterday. Thank you for reporting it.

Was it removed entirely or is it working as intended now?

Sounds like it’ll need a code patch to work properly. In the meantime, the spells that could cause this bug have been altered to prevent it from occurring.

Edit: just checked, and Devoted can’t target skulls. So it seems we’re still waiting on the full fix.

1 Like