Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

[CONTACT SUPPORT, COULD BE AN OUTDATED DEVICE ISSUE] Slow motion (Low FPS) Since Last Update

Platform, device version and operating system:
Steam, commodore a24a (4gb ram, intel celeron 1.80ghz, intel hd graphics 1gb) , windows 7 ultimate 64bits

Screenshot or image:
Cant upload a screenshot of my issue.

What you were expecting to happen, and what actually happened:
My game runs in slow motion, tried re-installing, drivers etc. Also, the turn on/off water effect buttom does not work for me, even if i disable it, I keep seeing the water moving there, reducing even more my fps.

How often does this happen? When did it begin happening?
Since last update, Ive been playing on this machine for the last year and a half without any problem…

Hope you can give me a way to solve it cause I wont be able to play anymore if not.

Thank you.

Did the game reset your Graphics setting to a higher one than you usually play on?

Hello Alison, this sounds very strange. Unfortunately, I am afraid that this could be due to the device that you are using. Windows 7 is no longer supported by Windows, and when your OS is no longer supported you can see degraded performance across all games and applications.

Please feel free to contact our support, but be aware that there might not be much we can do.

Could you describe a little more in detail where this slow motion shows up and what it looks like (e.g. moving the world map around takes forever)? If it’s just in battles, any chance your game speed setting has reverted to 1x?

1 Like