[Contact Support] Arena World Quest makes the game unresponsive and can't be finished

Platform, device version, and operating system:
Steam, ASUS VivoBook with Windows 11 Home

Screenshot or image:

What you were expecting to happen, and what actually happened:
I’m a returning player. The game tells me that I have the World Quest “Learn about the Arena from Luther” available, but when I try to do the quest, the game becomes unresponsive after I click on the Fight button. After I click on Fight, it shows a splash screen with a unit commenting on fighting me, and then it presents me with the screen with Luther and Fight button again. I can’t continue, the fight doesn’t load, none of the buttons work and I can’t exit this screen. I have to kill the app via Windows Task Manager.

How often does this happen? When did it begin happening?
It happened every time I tried to do it, but I do have access to the Arena. If I recall correctly, I could access the Arena before getting the Arena World Quest. It also happens on Android and iOS, I tried to do the quest on both my phones (UMIDIGI A11 Android 11.0, Apple iPhone 7 Plus iOS 15.3.1) but it doesn’t work there either.

Steps to make it happen again
It doesn’t matter what I do before. It has happened every time no matter if I tried first thing after entering the game or after doing any other thing first.

Welcome to the forums, ECAT. :innocent:

World Quests were released with the 6.2 update in early March. I haven’t seen any issues reported related to this World Quest, so it’s likely that the problem is with your account, as a returning player. Some game modes (such as Arena) were changed from being unlocked by Kingdom questline progression to Hero level and World Quest progression. Likely you did the Kingdom questline progression far enough to unlock the Arena, but the game thinks you need to do the World Quest since you’re Lv 60.

To get help with account-related issues, you can submit a support request here:


1 Like