Can't talk in Global chat or guild chat

I’m sure it’s something I must have done because it worked a while back but I recall a announcement was made that the chat had to be shut down for a short while and ever since then I could not get back into it.

When ever I go and hit that main bar on the controller to enter chat I get a message “Would you like to connect to chat?” (or something like that)

I also can not change channels and it’s difficult but I can click the disconnect button below.

Someone told me in the PC chat I need to reconnect and I don’t know how that’s done on PS4.


Global (none) means you’re disconnected from Global chat, but still connected to your Guild Chat.

You can get to Global (none) by clicking on the button to change channels,

and then clicking ‘None’.

To reconnect, click on ‘Channels’, enter the channel number you wish to join, and then click ‘Go’.

If that doesn’t help, then idk :stuck_out_tongue:.

When you said,

what did you mean?

I’m on PC, though.


I’m on PS4 and what I mean is when I click on Channels it ONLY makes a clicking sound and doesn’t let me actually do anything, no other window pops up.

1 Like

After many tries I was finally able to change channels and I put in 001 and then connected but nothing is there and I was still unable to chat using PS4.

Again if a moderator would be so kind as to help me out that would really be nice. :roll_eyes:

1 Like

They should be able to help you after the weekend, AEDT (Australian Eastern Daylight Time).

So after the weekend I might get some moderator help? Seems strange when the weekend would be the busiest time for people playing the game. Someone should be staffed over the weekend, one would think.

Hey Lagertha! Sorry for the delay.

Can you please clarify what is now going wrong with the chat since you were able to connect? If you could send a screenshot through that would be great.

If you’re having trouble sending a message, please take a look at this article. I realise it might seem obvious but sometimes it can be a little unclear exactly what to do - I actually wrote it after I struggled a little with the chat on PS4.

1 Like

Late last night I tried it again and was finally able to get into the chat on my PS4.

But here’s the thing, it was clunky, difficult to change the channel, I could hear the clicking sound but it didn’t respond. Also just as I did before when I changed the channel to 001 I waited a few minutes but nothing appeared in the chat window. Like no one was there or as I thought not really connected to the global chat number I put in. After trying it again later on I waited several minutes in the chat window (as I got something to drink) and when I got back to check it there was some folks there chatting. I typed in hello, but never got any response, although my text did show up so I assume that they just didn’t care to respond.

Anywho, I think it works now although it’s not very user friendly.

There was a tutorial for other things (Good ol’ Luther) I think you should have one for chatting as well. Or at least something somewhere in the game that you can go to and get help on something like this.

1 Like

I hope it gets worked out for you soon. :disappointed:
Chat it sometimes a fun part of the game, hopefully it will. The idea about the tutorial is a good suggestion btw


The team are planning on doing a chat rework later this year which should solve most of these problems but I can’t provide a specific timeline as to when. I’m a bit unclear as to exactly how the chat isn’t working if you could please clarify:

  1. Do you have any screenshots showing what happened when the chat wasn’t working well?

  2. Which button didn’t respond when you were changing channel?

  3. Did you get the “You have joined global chat (channel ###)” message in chat or was it completely blank?

Posting an image isn’t going to help much in this case. It would look like the first one I posted, a blank chat window showing no one is there.
I makes a clicking sound when I try to get the drop down window (like the one Jonathan posted)
It doesn’t respond when I try to post my message.

But like I said it works now, it’s just slow to respond and perhaps that’s due to the network being busy (I dunno) I also tried it very late at night here (around 1am EST) and it still seems slow.

I must say again the whole method of using the global chat when on the PS4 seems kind of difficult and I dunno how that could be change to make it easier for the end user (me for example)

I will say that you moderators are very good and respond to the members needs. I realize now that you are are a small group to cover a large community of users.
I have played other games (of course) and more often than not the Moderators are next to useless to the players or they just don’t care. That is NOT the case with you folks, I am glad to say.

Getting used to forum is also a little challenging. I don’t know how to change the text color but that a whole’nother thingy…LOL

Thanks and I look forward to seeing the update down the road.

Close this thread if you wish I’m satisfied.