Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

Can't get into Global Chat

Platform, device version and operating system:
Android 5.1.1 (MEmu emulator)

What you were expecting to happen, and what actually happened:

  • I had my chat set up so I was not in Global but was in Guild Chat. Either that, or I had completely left Chat.
  • I left my Guild about 15 minutes after reset (it took that long for my GW rewards to show up in mail).
  • While waiting on my transfer Guild invite, I tried to enter Global Chat by clicking on the chat tag on the left.
  • I’m prompted, “Would you like to connect to Global Chat?”, and I choose Yes (clicking No, then trying again makes no difference).
  • The screen dims a bit, I’m shown a short “busy” indicator, then the screen undims and I’m back at the map screen with no Chat.
  • I’ve tried from the PvP screen and inside a PvP battle, and still can’t get in.
  • My guess is the game is trying to put me into Guild Chat, but I’m not in a Guild, so it just aborts.

How often does this happen? When did it begin happening?
First time I’ve seen it. Thought I could reproduce it, but no luck.

Steps to make it happen again
See above and below, but what I thought would reproduce it failed. Still, it should be easy enough to find the error condition by inspecting the code.

Extra Testing

  • I joined a random Guild.
  • Tried to enter Chat, it puts me into Clan Chat.
  • I click Rejoin Global Chat, and am able to enter Global Chat.
  • I leave the Guild.
  • When I bring up Chat, it puts me straight onto the Settings tab.
  • I switch to Global.
  • I join a random Guild, and again Chat puts me straight into the Settings tab, rather than bringing up Global.
  • I switch to Guild Chat without leaving Global.
  • I leave the Guild.
  • I enter chat and it puts me into Global Chat (not Settings).
  • I join a random Guild.
  • I click “Leave Global Chat” and switch to Guild Chat.
  • I leave the Guild.
  • I click on Chat and it puts me into the Settings tab.
  • DID NOT REPRODUCE THE BUG.
  • I click “Disconnect” and go back to the Map.
  • I click on Chat, and I’m back on the Settings tab, but the buttons say, “Rejoin Global Chat” and “Disconnect”, so I guess the Disconnect did not got through.
  • I Rejoin Gobal Chat.
  • I join a random Guild.
  • I open Chat – I’m in Global.
  • I switch to Guild Chat Lite.
  • I “Leave Global Chat” and “Disconnect”.
  • I leave the Guild.
  • I click on Chat, and find myself at the Settings tab.
  • CANNOT REPRODUCE BUG.