Can't add traits to Cyclos


#1

What you were expecting to happen, and what actually happened?

I was trying to upgrade Cyclops with his first trait, but even though I clearly had enough traitstones to do so, it came back with a message that I didn’t have enough.

What are the steps to make it happen again?

Try to upgrade Cyclops’ first trait again. I should note that I was having connection issues about the same time this happened, so it could be related to that, but I tried upgrading the Summoner right after failing Cyclops 2-3 times, and he worked right off, so it’s still weird…

Do you have any screenshots or video you want to share with us so we can see the problem? Attach them to your post!

Here ya go:


#2

OK, seems my hunch about the connection issue was right. Given enough time it finally showed that he did actually get that first trait. Feel free to delete this post off the forum. lol


#3

I’ve had this happen before and it’s definitely connection problems at the time of upgrade. The solution is as you found - just wait a bit or reload the game.