Cannot submit a request


#1

What you were expecting to happen, and what actually happened?
Hi guys my login calendar is still deactivated and I want to submit a request but I cannot pass the CAPTCHA test to verify I’m a human. What is wrong?
What are the steps to make it happen again?

Do you have any screenshots or video you want to share with us so we can see the problem? Attach them to your post!


#2

Same here. I try to submit request, no luck :frowning:


#3

It’s a google image.


#4

Hello

What platform are you on? Does it work if you refresh the page? Can you submitting on different browser?

Perhaps also try without the screenshot. You can submit the screen later when we send an automatic email to let you know your request has been received.


#5

Hi. Tried on Windows 10, Mozilla ver 54.xx and chrome as well. Tried on Anroid Mozilla. Still the same. Oh yeah I also refresh page .


#6

It’s a google image, which is banned in some region, so if you are in one of those region, you cannot open it


#7

Which regions this picture is banned? I just want to make sure I’m not in the one.


#8

Primarily China and some parts of Russia.


#9

If it’s true. I’m not part of these countries. I’ll try again, but I don’t got any luck.


#10

Well then I don’t know Why the image won’t load for you