Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

Board Shakes WAY Too Much on Android

Since patch 5.4 came out, playing on Android has become both an unreliable and an unpleasant experience. The board shakes every time anyone does damage and/or casts a spell (I’m not going to research all the details, as that’s not my job).

Apart from being unpleasant to look at, the board shake also slows down the game considerably. One of the best examples is casting Skeleton Key. The board shakes for the initial cast. Then the board shakes again for the +10 damage trait. The animation effect plays in full for both bits of damage.

Please make the following changes:

  1. Reduce how often the board shakes.
  2. Do not allow the board to shake more than once per move.
  3. Allow other animations to occur concurrently with the board shake, rather than enforcing a delay for the effect to play out.
  4. Reduce how much the board shakes.
  5. Allow us to turn off board shake (both for aesthetic and performance reasons).

Thank you.

7 Likes

I vote for turn off option, extremely annoying for me.

I didn’t even realize there was a board shake. I had to turn down animation to x1 speed and even then barely noticed. Now I can’t unsee it. Good news is it’s not noticeable with x4 speed.

Edit: I agree with an option to disable. Any game that shakes screen needs an option to disable because of how commonly they give people headaches and such.

I saw this happen on the beta steam version yesterday with Phoenicia casts. From really really slowing things down I think I caught what happens. The pixels for the board location are slightly off so what we see is the board covering two slightly different positions. It’s not pleasant and as @Snooj says, It’s hard to unsee it

1 Like

It stopped happening today. Not sure what’s going on. It was really noticeable prior to today.

I wonder if this is somehow device specific? I had to really focus on slow animation to notice it, but for you it’s apparently really noticeable. If it gets noticeable again, can you share a video?

Yes. I play on three different android devices. Same account, same settings. On the least powerful device (Samsung Galaxy Tab S2), the shaking is very noticeable - the entire board seems to move side to side. Similar on the Pixel 2, but it looks a bit better, probably because of the smaller screen.

On my Pixel 4 on the other hand, no shaking or it’s not noticeable enough to bother me. And the game plays sooo much smoother, so much faster. Makes a huge difference in how quickly I can get through battles.

If I turn on power saving in game, I can get the same shaking on the Pixel 4. I can’t seem to get rid of it on the other devices though, even with power saving off.

1 Like

I think I’m going crazy now. Can I blame you? :rofl:

I turned on Power Saving since it’s always off. Yep, board shaking very noticeable even at x4 speed. Ugh. Gross. So, I turned Power Saving off AND IT’S STILL SHAKING!

Either it always shook at x4 and I just couldn’t notice before somehow, or it didn’t shake until I messed with the Power Saving settings. Ahhh it shakes now why :sob:

Edit: Restarting the game didn’t remove the shaking.

Edit2: My phone just warned me it had 15% battery, then instantly died. Clearly, my phone also disapproves. :rofl: (this is a joke, I don’t actually think it killed my phone, my battery is just dumb).

2021_04_05_12_50_46_1

Ahhh the shaking. So much shaking. :sob:

Sorry for the poor resolution. That was the only way to get the gif a small enough file size.

1 Like

Salty’s board in stream also shakes. Asked her about it but she never noticed. I now question if it ever did NOT shake…

omg, I am so sorry! I hope it goes away because it sucks so bad to have to play like that :sob:

I took a few screen captures, also in shitty gif quality:

Without power saving on ( :+1: ):
20210405_215011

With power saving on ( :-1: ):
20210405_215615

And here’s a mix, with power saving off, but still a bit of shaking:
20210405_221958

I’d prefer no shaking, but I can tolerate a little bit like in the last gif. The second one is nauseating.

2 Likes

Also happens on Steam, even with Power Saving set to off. Maybe the culprit is the details setting? I’ve set mine from ‘Low’ to ‘High’ and so far, so good.

Great replies, everyone! I think we’ve given the devs enough information to deal with the issue.
(Let’s hope they find time to do so.)