Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

Bluescreen Crash every time I Load the game since today's reset

Every time I try to go into the game I bluescreen…only happening after reset…what’s going on?

1 Like

Same here, PS4

Stuck here on loading assets xb1.

Can’t even look at my stats from GoWDB:
"The request was unsuccessful due to an unexpected condition encountered by the server. "

Just submitted a bug report…you guys may need to as well.

We’re aware of the issue, and are currently looking into it.

2 Likes

We’re just getting the fix to the servers now. Should be able to get into the game in about 10-20 minutes.

2 Likes

Mine was stuck at the loading screen for a while but is working now. Looks like the fix worked.

Working now, thanks for the quick fix!

Merlantis on PS4 is no longer reachable, yesterday it was via Blackhawk.

If you want a workaround to get there in the time being, open Hero menu > Collection > scroll down and press X on minor Water stone and again on the kingdom you want and you should get teleported there :smile:

Worked for me anyway, I can’t get to Merlantis otherwise currently.

1 Like