Alerts - opt in or opt out issue - Shows 1 instead of 0 when opting out, 2 instead of 1

Platform, device version and operating system:
PC, Steam client, Game version:, OS: Win 7x64 SP1

Screenshot or image:

What you were expecting to happen, and what actually happened:
I opted in in with Google Chrome Browser, got the message that’s not supported, so I went with Firefox Quantum by copying a link of my e-mail address. I also disabled the Ad-blocker for Gems of War in general.
In any case, Instead of seeing 1 Device, I now have 2 Devices, and Pet Alerts are not working for me.
There’s no option to use Opt ALL, so I can’t be opt out of all devices, no matter what I do.
Of course, I was using only one e-mail, the same one, always. The process when I opt out of the Browser, no matter which one (Google Chrome, Firefox Quantum), can never be set to 0, because the message says that I am already opted out - 1 connection.

How often does this happen? When did it begin happening?
Always. Since the beginning. I cannot reset all connections or devices to default state - 0.
Also, the Alerts are not working or showing for me as well.

Steps to make it happen again
Try to link the Alert feature to both Browsers, Google Chrome first, then the Firefox Quantum.
Link both. Then try to opt out. I think that the number of connections will not be at 0, but it will stay at 1, even if you opted out of all Browsers. I managed to set up 3 so-called Devices, but when I opted out, I was never be able to reach 0.


After you opted out are you still receiving notifications?

Regarding alerts not showing - this has been fixed so should work now.


Yes, I did. I am not sure if Alerts work for me. I have to wait to see it, but the issue for me still remains.
I can’t get number of devices back to 0 or 1 when enabled, even though I opted out from a single device I used with my only e-mail, PC.

What can I do to see only Browsers with alerts enabled: 1?

Do I need to create a Support Ticket?

Thank you.

Okay, Alerts are working for me. How can I opt out of all dives to see 0 instead of 2 or 1 when I have no Alerts?


If you’ve opted out and you’re not receiving Alerts any more then this is a visual issue.

I’ll pass the information onto the team.

Thank you. I tried to opt-out again and again, but I always get 1 instead of 0, regardless. I’ll wait for a fix.

1 Like

I am currently at 4 Alerts, even when I should have only 1.

This issue has been resolved for me.
Still, the developers promised to improve this feature to make it more convenient.

This thread can get safely closed.