4.3 update issues

I have had a few issues trying to “update” to 4.3.

  1. On Xbox One… Every time I start the game up (for the last month+, i guess) I get the Error Message saying something about server time out (which is really annoying), but usually the Retry loads the game.

The update is (likely) prohibiting this from happening. After the retry, I get a “Download” bar at the bottom of the screen and it almost instantly brings up the same server time out error - nothing ever appears to download (the bar never moves). Then I get to stare at a color circle that seems to spin forever (or at least multiple minutes). I try again and the same thing happens - or the variation where it skips the download bar and goes straight to the spinning circle.

  1. Amazon Fire: this will probably change (maybe already has), but the Fire HD is/was not grabbing the update… so the game will keep telling you have to get an update to play it, but it didn’t show up as available when I checked. I uninstalled and reinstalled which probably fixed the issue. Unlike the Xbox One, it didn’t keep my account link to the Steam version. Oh well
1 Like

I am/have been having the exact same issues.

1 Like

Same issue here. I tried everything, reinstalling, reconnecting router, hard reset on Xbox. Nothing works.

1 Like

Exact same issue.

Please let me play again! The game NEVER starts anymore since the update.

Yeah. I’m having a similar issue. I load up the game, the Download bar comes and goes. Then, all I see is whatever picture with “Gems of War” that pops up (usually, a pirate ship) and a spinning multiple color circle in the bottom right.

Normally, after a bit, something like “Press A to Start” would appear in the bottom middle of the screen, and I would hit A to load up the game. Well, it hasn’t come up in multiple minutes. I can’t start the game at all, I only see the Gems of War picture with the color wheel in the bottom right.

Very frustrating. Great update. Now I can’t play Gems at all…

1 Like

I have the same problem in Xbox One X. I was able to play the new update for several minutes, then the game crashed in the end of a battle.

I used to get the error message (server time out) every time I launched the game, but then clicked the retry and that always worked. Now it doesn’t. The download bar doesn’t move and the color circle keeps spininng forever.

I restarted the console. Didn’t work. I tried also other things, like move the game to an external disc, internal disc, deleted and reinstalled it. Nothing worked.

After I read other players saying the exact same thing, it seems there’s a bug in the update that prevents several players from playing the game.

I hope the devs can fix this asap.

1 Like

Hi All! Can you please contact support here if you are experiencing this issue on Xbox and let us know:

  • Are there any files downloading before you open the game? (not the loading bar but the bar above this)
  • A screenshot or better yet video of the issue happening