3.5 known issues (PC/Mobile/Console)

On PS4 if you try to sort “pets” by upgradable it will hard crash the game (blue screen than back to the 'desk top" on PS4 where you have to reload the game
Everyone in my guild can reproduce this error that has tried so I’m guessing it’s on 100% of all PS4’s

Regarding the extra turn bug, the dev team have fixed multiple causes of this issue occurring. Unfortunately in doing so another issue has cropped up at the start of the match. Please wait until all traits have finished activating on troops before making a 4 or 5 match at the start of a turn.

Kingdom Power Level Does Not Level Up after completing “Complete all quests” task - Known issue.

A little part is not translate into Spanish :wink:

I have a daily task that isn’t logging progress correctly. In these screenshots, you’ll see I have six ranked pvp wins in recent history. But the task (which was active this whole time, I haven’t reset it) only shows 2 / 10 progress?

pinging @cyrup @saltypatra unsure if this has been reported elsewhere…

Happens during the match as well, well after the traits are loaded.
Literally nothing has changed in terms of it between 3.4 and 3.5.


It was suggested I link my post here regarding an Adana issue with weapons not counting.

Adana Weapons Not Counting

1 Like

I can confirm this lack of automatic collapsing happens when you filter on Upgradable even when you have a Pet that is upgradable. Also on PC.

1 Like

Signed in to Gems to find a Pet rescue active with 5 minutes remaining, a challenge but doable. I didnt make it, Upon finishing the 8th battle I received the message ‘event has ended’ and an OK button. I was then Kicked out of the game. Unpon signing back into Gems all Pet rewards were in the mail as expected.

Please don’t kick players out of Gems of War after a Event Ends, instead returning them to the map will do nicely.


When it happened to me on Android I got a “Restart game” button instead of OK. Clicked it and then the game proceeded to restart.

@Cyrup I was doing a pvp battle and cast Krystenax summoned a Silver Drakon and killed the last enemy but now my game won’t end and I can touch the board.

1 Like

In fact, it only registers battles with 3 UNIQUE Ghulvania troops. Won 4 Bombot + 3 Ghouls battles and got nothing.

How is this possible? servers are still not synced that well.

1 Like

Minor visual bug, in my seconday guild, the purple statue does not seem to get the little check mark showing it is complete like the other completed tasks


That’s a known issue you have to cast another troops power up

You’ve always been able to fight you guildmates

He is not my guildmate. i was talking about his times. he was last seen 3 hours ago but fought me 55 minutes ago…out of sync.

And you can only fight guild mates in the arena.Not pvp.

1 Like

I’ve always been able to fight guild mates in pvp

maybe if you are testing their defense. no points are awarded though.

On PS4 we get a blue screen error when searching pets by selecting upgradable.

Edit. Pics.

Xbox, every time i finish dungeon or pet rescue and then go to pvp im getting internal error, i need to restart the game to make it work