Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

3.4 Known Issues (PC/Mobile/Console)

I reproduced it and caught it on tape!

Weirdly enough, not only did the AI ignore my extra turn, it also took two turns at the same time. I don’t even know.

(Also captured some background sounds; might wanna mute the video.)


I have a theory as to why this is happening. As the battle starts, notice the little white arrows above each team’s top troop are both present. These normally mark whose turn it is, and there should only ever be one. But there are two. The glitch thus would seem to trigger because the game thinks it is both players’ turns.



@Cyrup This has been happening a lot. Most of the times it happens is when

Exiting from the pvp menu
Editing team in the pvp and pet battle screens (unsure if it happens in raids I don’t do them)
Going to the troops menu from the main menu
Closing the game by the little x on the top right

Most of the time it fixes itself after 20 or 30 seconds but sometimes I have to close the game. After closing the game it’s fine for a little while but after half an hour or so it starts happening again.

oO that’s very interesting

Have reports from guild members about the pet rewards not being sent out if time ends.

on iOS I know of, dunno if any others are on other platforms. They have sent in tickets for missing rewards though

When you and AI both have only 1 troop remaining

  • If AI do skulls damages on your Yao and both troop die, AI win

  • if you do skulls damage on Yao (AI) and both troop die, AI win

This doesn’t seem fair imo


Known issue updates

Matching 4 or 5 gems does not always give an extra turn This is a bug specific to this update which have fixed on the development side. The fix will be available in an update in the future (a smaller one, not necessarily 3.5), we don’t have a time-frame at this stage. If you slow down a little, even by a second, it won’t happen (Note: Not slowing down as in x3 Speed. Literally wait a second or two before making your match).

Unable to connect to Guild Chat on mobile We are still investigating this. It would be great if anyone else with the problem who hasn’t responded already could let us know:

Can you please send through a screenshot of Guild chat is doing wrong (this can be sent in a PM)?
Does the blue spinning wheel that appears in the middle of the screen come up, or can you load, connect to chat and read it but simply not see messages?
Does restarting do anything to improve or worsen the issue?
Are you on PC or Mobile/tablet?

Other concerns

@cplns Please try linking your account and reinstalling your game.

@PHR33KP0W4 If you are logged into the PSN (not just the Playstation) please try deleting your save data and re-downloading gems of war. If that doesn’t work please contact support with ‘Technical Issue’ selected. Your account is linked to our servers/your PSN so it won’t be permnantly lost when doing this

@Smash All Pet Event rewards are sent via mail if they are left uncollected and the event ends, except Pets. If the 8th battle is not completed/won before the timer is up then no Pet is won,

@Max I think this is a known issue, I’ll check for you

1 Like

Based on reports from a few people in the guild, its not being sent out at all.

They have been in the 8th battle, won it, and then been told no reward cause it went over time. Then nothing was sent to their inbox.

To clarify: Just the Pet not being sent, or all rewards? And what platform?

All rewards based on what they have said.

They said they have submitted a ticket for it as well. Have had a few people say it over last couple of days.

iOS that I know of for at least 1 of em

1 Like

I am unable to change the difficulty setting for explore. The option just does not show up. I have made a post about this but thought I would mention it here as well. I have tried reinstalling. Doesn’t work on either iOS or PC. Curious if anyone else has experienced this problem… Thanks! @Cyrup


Guild chat still broken - cannot post to it, it’s read only

1 Like

Same issue here @Cyrup. No pet or any rewards of any kind received. I did submit a ticket last week and heard nothing back!

Hi @Cyrup - will there be another fix attempted for this? One of my guildmates now has the 3 Gnome task on two of his four task slots and support has told him that they can’t do anything about it.

1 Like

We will take some time to get back to you as we have a lot of tickets, but we have the tools to help you in the end (so regardless of how long it takes you’ll still get things back if they’re missing).

@Bleuu We are still looking into this, thank you

@Stan Aggh, this was fixed last week: the Pet Gnome should now be appearing in the Unowned Troops list. I forgot to update the Known Issues list (sometimes I have multiple copies open, I think it got lost). If the task is appearing in his task slot more than once we can fix this, or he can complete the task, otherwise maybe you could quote the ticket ID for me & I’ll look into it.

Seems stupid that those of us without all 3 gnomes would get the task though…

Stan didn’t specify whether their guildmate had the other gnome, so that would be good to know @Stan :slight_smile:

Otherwise I was referring to the gnomes specifically not appearing in Unowned, but thanks so much for pointing that out Icarium, it’s really helpful ! :blush:

Seems like common sense to limit it to those who can possibly complete it… as it stands it’ll be sitting on my list for god knows how long

When you say the problem should have been fixed, are you saying that the task shouldn’t appear for anyone now or just that the 3rd gnome should be available to make teams (assuming that a person has had the incredible good fortune to acquire all 3)? He can’t complete the task since he has only one gnome troop. I’ll see if I can get his ticket number for you.

Pretty sure she was refering to third gnome available

Well that won’t solve the problem for 99 percent of people that get the task. Adding gnomes to the exception list Along with bosses and towers, or limiting it to slot 1 would be solid fixes. Or sending everyone one copy each of the gnomes. That would work too.