3.0 is giving the dreaded lost connection error

Hi, I searched this and came up with some threads but no fix for the issue. I have my game loaded on an iPad, Andriod phone and Steam -PC. The only one working after the up[date to 3.0 is the PC running Steam. The other two give the Error - lost connection. Please retry when connection is established again. What is even stranger is I uninstalled the game on the iPad and started it without loading my profile and it worked. My profile should not be corrupt…it works fine on the PC. Please help, I am a huge fan of the game and miss using it on my mobile devices…

reformat entire iPad - reinstall
pressed the retry button when the error occurs many many times…

1 Like

Make sure you’ve submitted a ticket to support at https://gemsofwar.zendesk.com/hc/en-us They should be able to take a look at the inner workings on your account and see if anything is wrong.

I haven’t tried this on iPad yet, but next time you get the lost connection error, disable wifi and re-enable it, then click retry.

On PC, disabling and re-enabling your network connection fixes the retry… So maybe in iOS as well.


1 Like

Yeah, tried this on both devices, forgot to list it. No joy…

Speaking of this error and another related one (“This match is already over”): If these errors pop up during Guild Wars, people are going to be pissed. For instance, imagine someone winning a GW match with max points only for it to count as a loss due to “this match is already over” … that’s 20% of their daily matches turning into L.


That would be a bummer and every time a report those all they do is give me gold souls and glory but no PVP points back, and they always seem to count as a loss

I get the lost connection message all the time pretty much everyload screen should i put in a ticket

Yes! Please submit a ticket to our help desk that can be found here https://gemsofwar.zendesk.com/hc/en-us. Our support agents will look into it.

1 Like

Ok thank you

@ Tech Support. This issue has been fixed (by you), thank you. It looks like you increased the buffer window prior to timeout then error. Whatever it was it is now working…again, thank you very much.

1 Like