Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

[REPORTED] Manage team button not working

Happened to me today too with the delve event. Began the first round so there is no team listed, clicked Manage Team, and nothing happens. I’m using Steam. Have already tried closing/relaunching the game to no effect.

I posted a bug report for this today too. I am on Xbox

On PC/Steam it happens in the Labyrinth.
Other factions no problem but that one doesn’t let you go to the manage team screen.

Thanks for the work around tips, all. I usually use the quit game, restart method which gets tired after a while.

I’ve passed on the additional info to the devs, thanks everyone.

1 Like

The exact same bug recurred for Duergaroth. Both within the Event and using a Daily Delve Sigil. The work-around – changing the banner – also worked for both.

Could we please have an ETA for when/if this is likely to get fixed?

1 Like

I’m guessing it’ll get addressed in the same fix as the Skip button for claiming campaign tasks.

According to the known issues site. This will be fixed in version 5.4 patch.
Just a FYI.

1 Like

It still does not work

It’s fixed in the next patch. I commented as much right above yours.

@Saltypatra just never bothered to update the title.

1 Like