Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

[Known Issue] New Daemon Gnome - no illustration

Mobile version

Have you tried “downloading all assets”?
Also reloading game usually helps.

Thank you for your reply.
Yes, downloaded all assets, reloaded many many times.
Nothing, still the same, unfortunately…

It is not about assets or reloading, it was the same with Black Bjorn, Shahbanu spell picture and probably more. Black Bjorn(sic!) was only a big black rectangle, and magically started working after few months.

I’m experiencing the same bug.

After I finally got Daemon Gnone, I noticed I hadn’t downloaded all assets after the update. I downloaded the rest, restarted the game, and Daemon Gnome still didn’t have a picture. Restarted a few more times without any changes.

The last time I had a troop picture problem, I had to uninstall the game completely and reinstall it. I’d like to avoid doing that if possible.

EDIT: Ah, I thought I had read about this earlier. It’s a known issue and they were looking into it a few days ago.

1 Like

Yogghurty & Voq - thank you kindly for your replies.
It looks like I (we) need to wait for a miraculous self fix :slight_smile:

Same issue on Android - Galaxy A40. I double checked the game reports no additional assets to download, but the new gnome’s image still doesn’t show.

Good to know that this issue is being looked into as I have the same issue on my Note 9 cellphone

As you mentioned it, i seem to recall Black Bjorn had his picture blacken out(like nothing, just a plain black image/lack of image), and Lapina Explorer had his image as a grey-out peasant (peasant image but eveything in gray-scale) for weeks on my mobile. Currently they are ok, so it must have been fixed on the way.