3.0.5 Known Issues (PC/Mobile)

if you are running windows 7 there seems to be some issues. what browser are you using (i find that firefox has some memory suckage sometimes)

I found that setting either of the sliders completely off will not save, but move it a sliver up and it will stay there.

1 Like

same on my account. plz fix soon.

Purchased Eternal Flame weapon pack on Monday before the big update, now after the update the weapon is missing (dont have it). Ive already contacted support about it. Just mentioning it here in case someone has the same issue - or if somebody purchased the weapon pack on monday as well and havent checked and didnt notice their Eternal Flame is missing too…

I totally agree. This UI make me sad and I have pity for this poor butchered game.

1 Like

Garnok’s spell will end the game if he is the last troop and it causes him to die. This is despite the fact that he summons a troop. It’s similar to the Elspeth bug that was supposed to have been fixed. In the background of the below you can see that I won the game from Garnok killing himself despite him having summoned Fel’dras

Edit: and yes I was testing @mraider94 's team against my own defence :sweat_smile:


Playing in Iphone 6/Mobile only. I updated the app today and rebooted my phone after

Kerberos - Devour still showing in description as 50% not 40% as indicated

Famine - Mana cost is not showing any change, still at original level before patch.

Spooky Imp - Ability turned my Dragon Soul into a Wraith. Even though the slot read the traits for the Wraith, I was still getting the Huge Trait benefit for my Wraith every time I had a 4 or 5 gem match for the remainder.

General and Guild chat is sometimes showing up so small it is unreadable.

High rate of server connection issues and errors loading or exiting any form of PVP (rated, casual, Guild wars)

I attempted to go strictly cellular, and connected from 2 different wifi networks, same issues persisted.

Anytime I get a text or call the app crashes. This did not happen previously and I was able to choose to ignore or minimize without any interruption to gameplay

Kraken - Multiple occassions where dragon soul performed only 19 damage when tooltip reads 20, only seems to occur specifically to kraken. Had the same issue occur for attacks from other troops, Kraken seems to have a glitch where they do not always take full damage or always have 1 life remaining regardless of damage done.

Performed 30 damage to kraken with 23 life left and it survived with 1 life

Barrier - I have been devoured through barrier by kerebos and kraken

General comment/opinion: so far I liked the old engine and old UI better. If at all possible revert to old for both.


totally agree, half the draw of this game was that it was great while being simply, I feel like they are getting too fancy now, I want the older game back, fingers crossed they back out all of these updates.

Gems of War now uses 2.6gb of RAM! wow!

I have a thread of similar intent here:


Steam overlay no longer activates if I launch the Gems of War app from a pinned taskbar link (the game will still play/log in just fine, it just wont “look” for Steam). You have to launch the game from in the Steam client or via a link that opens it via the app id. I’ve worked around this by having my taskbar link point to the url that opens the app via steam ID.

Income collect opportunities are occasionally not appearing. I had my external tribute timer set and tabbed back into the game as usual, but clicking on the kingdom did nothing. The pulsing gold overlay indicating income was ready to collect did not appear. The indicator continued to not appear and I tried clicking several times over the next 20 minutes, before eventually restarting which allowed me to finally collect tributes. This may have something to do with the overlay being up when the income collect opportunity first rolled over, but it was never a problem before, and I could occasionally beat the flashing gold indicator even appearing. Do I really have to relaunch the game or play a match every time I want to collect tributes when I’m not actively playing now?

The menu you get when clicking on any kingdom is extremely sluggish (almost a full second passes between when you click the kingdom and when the animation starts) and clicking again no longer dismisses it. After some testing, this appears to happen because there is a forced delay for the screen to move into position whether or not the kingdom in question is already center screen. I guess it isn’t major, just a slight annoyance. The smooth scroll over to a non-centered kingdom when you click on it is also for some reason replaced by a jarring two-step scroll. Again, not really a bug, and I’m not sure I’d welcome resources getting put into “fixing” it.

I’ve received purchase nags for Path to Glory twice now. The first one was expected, since its a new version and whatever advertisement viewed flag hadn’t been set yet. The second one not so much. Only two so far, and I’m hoping this was because whatever flag that said I’d viewed it didn’t get set properly the first time.


Just checked it myself… youre right - 2,5 GB of memory, holy frikking cow.

The only possible explanation is some massive memory leak of some sort, considering the entire game takes up only 700 MB on hard drive.

Expect to get that every day, about 30 seconds after you log in. It’s been that way on console since the previous update.

Wouldn’t be as bad as a new player or if there were actually different offers shown, but as someone who has already put hundreds of dollars into the game and knows exactly how “valuable” these pack purchases are, that is fairly appalling.

1 Like

Because of the update the language settings are set back to the system language, and those translations aren’t really the best… I want to play in English, but it doesn’t change, no matter how often I click on the US flag in the options. :frowning:
Hoping for a quick fix

Guilds are still being credited with too many battles in guild wars:

On Unity (console) you often have to force the Game to communicate with the server. Entering into the Mail tab even though its empty or playing a battle ‘should’ get your Tribute to pop up. Hope this helps.

1 Like

I’m finding that isn’t working reliably anymore. I’m sure I was well over an hour played this morning, pinged the server multiple times (checked guild stats, collected seals, checked mail, etc.) and nothing. I had to leave for work so missed a tribute chance because of it.

@Sirrian @Saltypatra

NowayJoe2Go’s Issues:

I submitted a ticket for my first issue already, but since my Guild now has a more pressing Guild Wars issue, I will simply post them both here.

Issue 1: VIP Team slots are not unlocking for me. On iPad / iPhone, I gained a level and extra Team slots did not unlock correctly. Then I purchased a $5 Gems pack from the game on itunes and they still did not unlock.

UPDATE: Although this did not work correctly for me on iTunes as stated above. I was able to level up again on PC and the extra Team slots did unlock. :smiley:

Issue 2: How are GW Team Total Battles being calculated on the Results screen? DruidsGlade is in Guild Wars with Hoguns today. Our GW Battle total says: 147 / 150 But the Individual Player Totals says 138 / 150: I’ve spoken with our Guild, and the Totals are inflated and incorrect. IE, we have not played the battles. In talking with other Guild Leaders, I understand others are also having this issue. Why does the Battle Screen say more GW matches are completed versus Reality?

UPDATE: It looks like this is a math error on the Team Totals screen. However, I have not checked the math to confirm the total scores are correct.


That’s really unfortunate, as the Mail check used to work. Perhaps 3.05 just broke it across all platforms then.