Hoard Quality Upgrade 100% Chance - Still fail


#1

Ok, so this to me is the dumbest thing ever.

Why do they even bother to visually display the upgrade chances if it’s all a scam. It happened to me like 3-4 times already.

It also fails a hell of a lot at 90%, but at least you think to yourself that you are unlucky, there’s still a 10% chance to fail.

But at 100% chance, fail… this is just stupid, devs need to learn some math.


#2

What treasures did you add that failed? What was your Hoard quality? This does sound odd.

@Lyya, check back on this in an hour to see if the OP cleaned up their language.


#3

Edited for content. OP, please watch your language.


#4

I can’t remember what I used every time this happened, but, last time I used 2 King’s Crowns (25%), 2 Priest’s Chalice (20%) and 1 Gold Ring (10%).

Hoard Quality was 8/10 for this last try (and remained the same obviously). It was a bit lower for the other failed attempts.

PS: Sorry for the language, I was pissed.


#5

In my experience, you get better results using 5 of the same item.


#6

When you add treasures that equals 100% the hoard quality number displayed increases by 1. Then when you select to actually spend the treasures the number stays the same of course. When you add treasures that don’t equal 100% it works differently, the number only increases when you actually spend them if successful. Maybe this is what happened.


#7

It’s just a weird way in which the upgrades are displayed like Fleg explained. I also found it strange the very first time but then since my calculations ended just like expected i understood it and payed more attention the next time i invested into another hoard up to level 10 to confirm.

All my three hoards are at quality level 10 by now and none 100% chance upgrade failed.


#8

No, sorry but this is not what happened… like I said, I was also confused first and second time it happened, but by the 4-th time, I was paying attention, believe me.

100% Chance of upgrading… still fail.

I’m just surprised no one else came forward with this issue, maybe it’s a rare bug or something.


#9

It sounds like you need a dev to check logs and see what might have happened. Given that it’s Sunday evening for them right now, this probably means waiting another day or two. I hope they can clear this up, because it’s obviously frustrating having an apparently 100% chance fail.

Try submitting a support ticket, which will hopefully get to them and not 505 Games; you don’t need help from the publisher for this.