Empty board in GW battle

What you were expecting to happen, and what actually happened?
Gem drops when the battle begins… No gems…

What are the steps to make it happen again?
Launch a GW battle…

Do you have any screenshots or video you want to share with us so we can see the problem? Attach them to your post!

1 Like

Just got it in normal PVP, was looking for the right thread…

Aaaand it counted as a loss, excellent…

I did an Alt+F4 and it did cound as a loss… I tried again and…

It seems that I wil not be able to do my GW battles…
EDIT: no it was couting as a lost battle… I was misleading because of the lack of Red cross on the Soldier…

What devices are you all playing on?

Same here on both Windows 10 and Android. Blank board in Guild Wars, counts as a loss when exiting.

PC for me.

I just started it up, and first PVP was blank. Closed it and restarted, and the same.

Same thing started happening to me in explore. Thought it was due to the crappy laptop I switched to, but reinstall did not help. Happening on my normal PC as well.

Also, kingdom levels appear to be all over the place. Khetar was showing as level 17. When I tried to go into the kingdom screen, I was treated to this, and could not get out:

PC version, Same thing happened to me Kynetarse, also the blank grid is PvP as well, not just guild wars.

Same here with the PvP Glitch. I submitted a report about it and came here to see if others were having the same issue. It’s good to know I’m not the only one, so I’m sure it’ll be fixed soon.

We are all working on it now.


Losing out on 10 guild battles because of this…

Happened to me on mobile. Was on my last five GW battles. I was a perfect 25-0 (no troops lost) too! :frowning:

Hero Button Glitches out the game as well. Pc as well

No problem so far on iOS (iPad).

ios has been working fine for me as well.

Same here.

And another day, where the game really doesn’t want me to play it…